Help- Lost power during firmware update!

Hi, my building lost power while my Grobo was going through a firmware update, and now will not turn on at all. I see the blue light on the power supply, as well as the small blue lights on the ec and ph meter plugs inside the lower trapdoor. I’ve tried all of the resets listed here, but still nothing!

1 Like

Hey @Daniel_Lendon

Your unit is not showing any color light from the main LED signal correct? (The light just above the door that typically is pulsing blue when all is running well)

That’s correct. Only from the lower board where the power supply comes into the grobo.

How long are you leaving your unit unplugged during your hard reset? Should be unplugging for 30 seconds at least before plugging back in. Are you doing so?

Yeah. I’ve left it unplugged for a few minutes and tried. Still nothing.

Have you tried holding down the control/unlock button on the back of the unit for 10 seconds then releasing?

I’ve tried that. As well as holding the button down for 20 seconds while plugging it back in.

Are you hearing any noise whatsoever from your unit when plugged in?

None at all.

Ugh, man what are the chances that you lose power during such a crucial 10 minutes! You’re going to need to submit a support ticket if you haven’t already done so and make do until the team is in on Monday to respond. Do you have an external air pump that you can run to keep her breathing? Also what stage of growth are you in? She will need some light during her normal “daytime” hours, anything will do, just want to keep her mind right until the support team gets you squared away.

1 Like

I’m surprised there isn’t a way to boot the grobo from the previous/original firmware?

I do have an air pump. And I’m on day 12 of early veg. with a clone, so probably a week away from late veg.

Got you, yes that would be nice. But with little to no control over the unit you are definitely stuck waiting on support. You’re still early on so it won’t upset her much so long as you get that external pump running and keep some light on her so she doesn’t get confused and flip early.

1 Like

Hi Daniel. I hope your machine is ok! The factory resetting isn’t helping correct?

1 Like

No the factory reset is not working.

@Daniel_Lendon did you try pressing the button on the back of your machine for 8+ seconds? This should help reset the WiFi. Not sure if it will help though.

I’ve tried every reset. Nothing has worked.

How do I open a support ticket?

1 Like

1 Like



@Daniel_Lendon any luck?