My Grobo wont connect to WiFi

I need some ideas. I’ve power cycled several times. I’ve tried to completely reset but it’s not connecting to wifi. After my last drain it disconnected. I haven’t been able to get it reconnected. It’s still stuck on my old grow. I cant end the grow.

1 Like

Turn your phone off and back on :joy::rofl::+1::v:

I’m using my computer not my phone. I could never get my phone to connect

You’ve probably already done this

pull the power plug

Hold down the door button on the back for 7 seconds to release any static charges being held by the boards.

Performing a factory default next if you wanted.

  1. Unplug your Grobo for 20 seconds
  2. While plugging it back in, hold the user button down from approximately 20 seconds
  3. You will see the User LED light flash a pink and yellow pattern
  4. Your User LED light will then go red > green > blue then back to solid green
  5. From here, you can reconnect to WiFi
1 Like

Same diff though :+1::v:

Have you tried to power cycle your router and modem? I had to do that a couple times to get it to connect.


I can’t get android to connect but iphone does

Sorry if this is obvious but I would reset your modem and wifi router…ensure you have enough free DHCP clients avail in your router as well if someone has limited the # of connections. then reset the grobo and see if it reconnects.
I really wish we could just manually enter the WiFi settings, I am not a fan of the auto join process, but I’m in IIT so to me its like being forced to wear water wings and a snorkel to just go sit in the hot tub :wink:


Being able to remove the old access points might help too… I noticed mine still tries to connect to access points I no longer have plugged in, it at least queries to see if they’re still there… (had issues connecting one day and was watching wifi traffic to see why)

Nice idea. I liked this.

1 Like

Grobo has always been iffy on wifi connections for me. It will say it’s not connected when it is and vice versa. Th ed saga continues…

Try to disconnect and reconnect through the web app

The only thing I have is the web app

It could be time to update your router.

It’s not my router. Everything connects and works fine just not the grobo.


Fight on

1 Like

If this was me I would try

  1. unplug modem and router(s)
  2. wait 1 min with everything unplugged
  3. plug back in all modems and routers
  4. put grobo into wifi connection mode from web app

Some/most routers will assign IP addresses after a power cycle so seems like a best chance of working

As an aside I sure wish the MAC address was visible in the web app somewhere… is it?

1 Like

Honestly guys try a different tool to connect. Like I said setup on android DOES NOT WORK but on iphone its instant connect. Couldn’t tell you why. Also doesn’t work on pc

1 Like

My Grobo only connects to the 2.4ghz (wireless N) bandwidth of my wifi. I don’t believe it can connect to 5ghz (wireless AC). Try troubleshooting that configuration on your modem/router.

My Grobo is literally the only device in my household using that lower bandwidth, so it’s not unheard of for other devices to connect fine.


That might be my problem. Once its connected no issues it’s just that initial setup I could never figure out why