Grobo stuck flashing hot pink light [RESOLVED]

Hello growers. I’m in need of some serious help. I’m day 61 in the flowering stage. Everything was going ok, until i came home to change the water on the grobo, but it wouldn’t connect. I didnt have a green solid light so I continously attempted to get the green light to connect to the wifi. The light might of cut on for 5 seconds b4 cutting right bk off. I read on a post here, that a factory reset may be in order. So I tried tht now like 1 1/2 hrs later. Its stuck on this flashing pink light. Doing nothing. I read that, pink flashing lights, or fuchsia lights, means its downloading firmware. Does it take hours to download firmware? But I do think I can hear the fans still moving inside.
Another concern I’m having is b4 the flashing pink light, when I was able to still open the door. There was no light inside. I dnt know if theirs no light due to the recipe calling for 12hrs of darkness or if theirs a light issue. I was told by a family member tht while I was away. The lights were flashing rapidly. Unlike any mode we’ve seen from from the grobo so far. Someone in this forum mentioned having similar lost connectivity problems and their lights were malfunctioning aswell. Someone please get me back on track. Thank you

1 Like

Try holding the button at the back down for 10-20 seconds, while watching the status led at the front. You’ll see it go green. At that moment go to the app and then start the wifi setup process. It helps to have the app open and ready to connect as soon as it goes green

Have you tried using the app from the app store?


I was doing this this with no luck

I’ve found that unplugging it (for about 20-30 sec) and plugging it back in might help if it’s not “staying green” for long, do a reset and then hit the button as soon as it finishes the startup sequence (the “light show”).

I think a firmware update recently made this process better, but in the past I used to have a heck of a time racing to connect after the light went green as it seemed to “time out” after about 20-30 seconds and need the button to be pressed again to go green again. After you get it online I’d suggest go to the app and in settings somewhere is a button to check & update firmware.

Are you using the app from the app store or the web-based app? The one from the app store (I believe) has a much better setup process.


I’m about to try that again. The crazy thing is. It’s been in this state atleast over 12 hrs. I’m hoping the plant hasn’t taken a hit.

That worked this time. I did it twice last night. That’s crazy. I think how you worded it made me understand better. Thank you

  • ([RESOLVED]):


1 Like