Anyone with Wi-Fi issues?

Thought I’d ask if anyone else is facing constant drops on their Grobo’s? I have 2 and nearly every day one of the 2 has a fast flashing blue light. I unplug / plug back in and it connects. I’ve been having this since the first one was purchased, and we have replaced lots of parts from motherboard to wifi antenna to flashing new firmware. We have moved the Grobo to a different room and still the same issues remain.

Ex IT guy so I’m running a decently elaborate home UTM / wifi solution - Ubiquiti based. Would have went Meraki but can’t justify the yearly licensing for essentially home use. I do have a call with a Grobo engineer this evening, but I was curious if anyone else is facing this. Setup:

1 X Unifi USG Pro 4. 0% utilization on average.
1 X Unifi 24 port PoE switch
2 X Unifi AP AC Pro’s.

I have full DPI setup on the UTM and every device is checking in and managed. The ONLY devices I have constant drops with are the Grobo’s. In fact, when I came home today one of them was offline.

I’ve attached a few pictures below of screen grabs from the UTM showing traffic and wifi experience daily and over 7 days. I also attached one of our IoT light switches (Kasa HS220) as it seems to have a very simliar wifi signature - likely the same module manufacturer (or not - what do I know, haha). However, both the HS220 and the Grobo’s only operate on 2.4 Ghz, which I found odd the Grobo wasn’t dual band.

Lastly, I purchased an external Wifi Antenna of Amazon that plugs into a laptop wifi module (what Grobo uses) to see if I could fix it this way. I won’t look at doing this until I clear it with the support team that I don’t screw my warranty. But, someone (in support) mentioned the design of the Grobo creates a faraday cage around the wifi adapter which could be part of the issue. I can see that being true, so hopefully the external antenna will fix this possible issue - if I’m approved to do so.

To be clear everyone, I’m not looking at hacking on Grobo. I love my devices and the team making / supporting them, but I do believe there is an inherent flaw in the wifi design / module utilized. Looking forward to construction conversation and I’ll report back after my call tonight with the Grobo engineer.


I’ve had the same issue for the last 10 days on one of my units. Actually had to go through the setup wifi function again.
Can’t wait till the team @bruno setups the software application side for security for us and better tools and ways to implement them soon. I mean you guys got a 400k injection from dragons den. Just saying…sorry not sorry. Hahaha


Yeah I just had this happen about 4-5 days ago. Had to set up the wifi again. Then a couple days after, had to unplug and then it reconnected. This is the first time I’ve noticed the problem for me since I got the Grobo in Oct of 2018

1 Like

Yep, if it doesn’t get better after an attempted reset, I ended up connecting mine to the guest network. Not sure why it worked, but as the only device logged in it works… the main network flashes constantly

1 Like