Dreaded wifi connectivity issues

I throw this out with the hope I have missed something!

Problem: Grobo disconnected from wifi, will not re-connect.


  • Disabling all 5ghz aspects of the Eero mesh system. Still no connect.
  • Using an older Apple Airport Extreme, and naming the 5ghz and 2.4ghz separate SSID so I can focus on the 2.4. Still no connect.
  • rebooting Grobo, still no connect (rebooted many times now, and oh yeah, since I rebooted and can not connect my grobo is not executing the current recipe.)
  • Call grobo Support - Did this they asked me to try using a hotspot from my phone. This worked, for 20 minutes. It then disconnected, and no amount of
    re-trying will get it to connect to my phone, my wife’s, etc. Support saw it would connect to the phone, so in their minds this is my issue. Which it likely is.
  • Tried re-connecting from the app, and my computer (iOS, and Windows respectivly) No go either way.
  • Have reset the machine to be listening (green light) for wifi over 36 times and counting.

I am at my last resort, there must be something simple I am missing. Much longer and this grow will be toast.


Is your grobo app up to date? You can go into settings click the about and it will show you connection and version. If it says update firmware. Do it. Also in the App Store find grobo app and click on it to see the latest version and any updates they’ve done recently. That’s about all I know. Hope it helps :+1:t2::sunglasses:


Thanks for the idea. I am on iOS version of the app and that is current. For the Grobo itself, when you go to settings, it of course says “Connect to Wifi and pull to refresh” under firmware version.

1 Like

You shouldn’t have to pull to refresh anymore. I just went through that. Grobo fixed that a week or so ago. Crazy :stuck_out_tongue_winking_eye:. So I’ve had connectivity issues with other items in my home. My internet provider was able to help me figure it out. I would try that if you’ve done everything else. I hope you get it fixed. I know it frustrating. Good luck :+1:t2::crossed_fingers:t2::sunglasses:

1 Like

Thank you! Called the ISP as well, but they were not of much help. I will try again, and hopefully get a more enlightened support tech. :wink:

1 Like


- - - [2021-10.20]:



Sorry..~~ (4)






~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~

1 Like

Very much appreciate everyone’s help here. I honestly have kind of given up, and going to end this grow 8 weeks in. I can not connect other than briefly through my phone’s hotspot…and that is briefly, maybe stays connected for 5 minutes. ISP says all is good, so I checked my other 2.4ghz devices, and they are good to go. Disconnected, and reconnected fine, multiple times. Considering the Grobo app on my phone will sometimes not even allow me to use the “re-connect to wifi” feature, corrected by re-booting my phone, I have a hunch this is Grobo related either in the app or device. Who knows at this point. (I have even taken old iPads from years ago, and used them to connect…generally works once, and then the device hangs when trying to connect a second time. Wish I still had my android to try)

This community is great, and again, thank you for the support. I simply do not have the time to be playing around with this for hours each day. If I find a solution, I will post here. Until then, RIP my little Gorilla Glue baby!


I would get your home system setup and working the way you want it without worrying about the Grobo. Make sure it works with ALL your other devices both 2.4 and 5. Take you phone and/or another device where you have your Grobo and check the wifi signal strength. If 3 bars or more you should be OK, if 2 and lower you might have some problems and want to move your Grobo or router.

Next I would turn the Grobo off and remove the app from your phone. Restart you phone THEN reinstall and setup the app. Next turn on the Grobo and restart the wifi setup. If still the same problems I think the Grobo wifi chip or antenna piece needs to be replaced.

I am a big CordCutter and we do wifi trial and error all the time.

1 Like

You can still pull down to refresh even in the newest app with iOS.


I hear you…I work in the tech industry, and have my networking down pretty well. I did get all my other 2.4ghz devices going. Grobo still doesn’t want to connect. So, Internet works fine, all devices connect, save for my Grobo. That’s why I am going to take a break from the Grobo for awhile.

Tried your suggestions about removing the app, and the like. Challenge I had was that if I re-started the Grobo, I would lose the recipe it was running if unable to connect. Since that is a moot point now that I will be ending the grow, I will play around with it when time permits, without worrying about hurting the grow.


Couple of things to check when you get back around to it:

  1. I’m assuming you can get to https://my.grobo.io to access your Grobo unit there.

  2. Are you able to load “http://my.grobo.io:80” from a browser running on windows/mac/linux on the same network as your Grobo? The url is important because you want to check if you can load the non-ssl version of the site.
    If you can’t, either your router or your ISP is blocking traffic to the Grobo server.

  3. In that case, either your router is blocking outbound traffic to either our server (my.grobo.io) or non-ssl sites (i.e. port 80), or your ISP is.

  4. Can your ISP see the request when you try and load the http://my.grobo.io:80 page? If not, it’s probably your router. Disable all firewalls, built-in virus scanners etc. on your router and try again.

  5. If they can, is it being forwarded out of their network correctly or are they blocking the traffic somewhere?

Good luck!


Thanks Matthew. Still playing around with it as it is friday night :slight_smile: Answers below:

  1. Yes
  2. Yes
  3. NA based on the above.
  4. Yes they can.
  5. The guy I spoke to at Comcast claimed no problems on their end. Please please do not make me call Comcast again. So painful dealing with their support. :wink:

I can not even get the box to attach to my phone anymore when I turn on my hotspot.

Anyway to create a wired ethernet connection? I know there likely isn’t, but sure would be nice.

1 Like

I was unable to bring myself to stop my grow on day 67, so figured I would post my alternate solution. I have the below UFO grow light on a timer, dose my own nutes, and have a small “drill attached” pump that can pull out the water, and add more. Of course also added a separate bubbler as well.

Obviously this is only for this grow, after that will need to convert to a tent.


That is great and works too. :grinning:


Thought I would post the “sorta” solution I found. Basically I had to shut down my Eero Mesh Router, and buy an ancient 2.4ghz router.

• Set Eero Mesh router to mode which only broadcasts the 2.4ghz network. Not able to connect.
• Unplugged everything from the network, including the Eero Mesh router, and the Apple AirPort X
• Shut down cable modem.
• Installed ONLY 2.4ghs router.
• Was able to connect.
• Shut down everything again
• Installed Eero router,
• Added 2.4ghz router of a port of the switch attached to the Eero (and moved it literally on top of my Grobo)
• Said multiple prayers to multiple deities, take your pick, I hit them all.
• Successfully connected Grobo to the 2.4GHz, which hangs off the Eero Mesh.
• Prayed to too many deities, don’t know which one helped?

Been running for 8 hours. Will try and add the Airport router of the Eero as well. If it doesn’t work, no biggie, I’ll take the Apple Router back off.

tldr: Grobo is super touchy about 2.4ghz connections. If you are having problems connecting and can isolate to 2.4, it’s a good idea. Both the Apple and Eero routers allow you to shut off 5ghz, and only have 2.4, but the Grobo would still not connect, so I really had to isolate.

I still don’t know root cause, but am going to keep digging. I don’t understand why it would not connect to either the Apple Airport’s 2.4ghz network, or the Eero’s. I was able to isolate them both, and still no connect.


I am Admin in a Cordcutting group and been for 20 or so years and sounds like your equipment maybe as no one uses that old Apple router anymore, think they have been discontinued and not been sold in about 4 years give or take. I also am not sure you can actually pick to use the 2.4 band directly on Eero or at least you never used to be, what I won’t use them, maybe that has changed.

Unhook all your devices and try this for $30 and I bet it will work fine. Easy return to Amazon.

1 Like

Great minds think alike. That is exactly what I did. Bought a cheap2.4 router from Amazon. Only hooked that up, connected. Shut it down and started the Eero Mesh, connected the TPLink, and it still connected.

I hear you on the Apple router, but I only use it for 2.4ghz connections to my IoT equipment. Added back in and it works. All living in harmony now.


Great thinking. Sorry about this WiFi BS i know how you feel.